[РЕШНО] Приказ 221 Сведения в Роскомнадзор - Принято - MIKROTIK BGP c РКН

Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
Ответить
[РЕШНО] Приказ 221 Сведения в Роскомнадзор - Принято - MIKROTIK BGP c РКН, настройка на mikrotik
Нам пришло письмо из РКН:
Нам не удается установить с вами BGP сессию.  Вам необходимо связаться с оператором ЦМУ ССОП.  Телефон для связи 8-495-XXX-XX-XX доб. XX-X-XX
На текущий момент мы рекомендуем использовать IP-адрес 185.224.228.193  и  AS65211
Проверьте, что с вашей стороны выполнено следующее:
- открыт доступ к 179 TCP порту маршрутизатора с любых портов IP-адреса ЦМУ
- сконфигурирован параметр BGP Multihop (количество хопов определить трейсом до IP-адреса 185.224.228.1 + 2 про запас или указать заведомо достаточное количество хопов, например 100 или max-255)
- переключена сессию в passive
- настроена подача full view или  конкретный маршрут (default rote).
С уважением, ЦМУ ССОП

Кто может помочь настроить подобное на MIKROTIK BGP c РКН ?
Нашел на другом форму, но как это все на микротик переложить, на CISCO:

Код
protocol bgp bgp_rkn
{
        debug all;
        description "Roskomnadzor";

        local as XXXXXX;
        source address X.X.X.X;
        neighbor 185.224.228.193 as 65211;

        import none;
   #import filter bgp_in_rkn;
        export filter bgp_out_rkn;
}

filter bgp_in_rkn
{
        reject;
}

filter bgp_out_rkn
{
        if net_martian() then reject;
        accept;
}

function net_martian()
{
        return net ~ [ 169.254.0.0/16+, 172.16.0.0/12+, 192.168.0.0/16+, 10.0.0.0/8+, 
                127.0.0.0/8+, 224.0.0.0/4+, 240.0.0.0/4+, 0.0.0.0/32-, 0.0.0.0/0{30,32}, 0.0.0.0/0{0,7} ];
}
netflow - ipt-netflow https://github.com/aabc/ipt-netflow

snmp - в работе, непонятно как нагрузку ограничивать в случае чего...

В конфиг bgp bgp_rkn { нужно добавить еще passive; multihop; 

У меня без этого не поднялось.

BGP multihop - cпециальная функция используемая для установления BGP соседства с роутером, который не имеют прямого подключения для данного. (т.е находят через несколько hop и нужно увеличивать TTL)

Код
/routing bgp peer
add in-filter=RKN-bgp-in multihop=yes name=bgp_rkn out-filter=RKN-bgp-out \
    passive=yes remote-address=185.224.228.193 remote-as=65211 ttl=default

/routing filter
add action=discard chain=RKN-bgp-in
add action=accept chain=RKN-bgp-out prefix=XX.XXX.XXXX.XXXX/22 set-bgp-prepend=10
add action=discard chain=RKN-bgp-out


общее понимание как настроить BGP тут
Услуги Системного Администратора - Работаю только с Юр. Лицами по договору обслуживания.
Страницы: 1
Ответить
Читают тему (гостей: 1, пользователей: 0, из них скрытых: 0)
Форма ответов
Текст сообщения*
:) ;) :D 8-) :( :| :cry: :evil: :o :oops: :{} :?: :!: :idea:
Защита от автоматических сообщений. Введите символы, изображенные на этой картинке в поле ввода &quote;Код подтверждения&quote;.