105 no buffer space available (не пингует и не пингуется)

Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
Ответить
105 no buffer space available (не пингует и не пингуется)
По системе мониторига обнаружили что микротик перестал пинговаться
зашли через нейборс - через мактелнет
и визульно все ок.

Но при попвтке пинга с него ничего не пингуется вот с такой ошибкой: 105 no buffer space available
Скорее всего вы если сделаете так то увидите:
/ip route cache print
     cache-size: 65536
max-cache-size: 65536

Известно что это баг, ядра линукс 3.6 и насколько известно проблему вызывает: Переподключения интерфейса OVPN ответственны за утечки кеша маршрутов.
Последние сообщение о подобных ошибках были на версии:  6.47.8

Решение:
1. Обновиться - до лонг-терм
2. ip - settings - попробовать отключить route cache (честно не пробовал) - не до конца понимаю к чему приведет.
3. в 7 говорят выпили route-cache т.к на более новом ядре (переходить на 7 ку - пока так себе решение)

4. СКРИПТ N1 (зарпускать раз в сутки)
Код
/ip fi connection tracking set enabled=no;
:delay 90;
/ip fi connection tracking set enabled=auto;


Либо скрипт2 тут с перезагрузкой, это если первый вариант не решил:

Код
:local uptime [/system resource get uptime];
:local date [/system clock get date];
:local time [/system clock get time];
:local identity [/system identity get name];
:local freememory [/system resource get free-memory];
:local cpuload [/system resource get cpu-load];
:local freehdspace [/system resource get free-hdd-space];
:local cache [/ip route cache get cache-size];
:local maxcache [/ip route cache get max-cache-size];
:global datum [/system clock get date];
:local percentused ((100 * [/ip route cache get cache-size]) / [/ip route cache get max-cache-size]);
:log info "RouteCacheUsed: $percentused %";
:if ($percentused > 17) do={
/tool e-mail send server="smtp.gmail.com" 
port=587 start-tls=yes 
user="XXXXXXXXX" password="XXXXXXX" from="XXXXXX@gmail.com" to="XXXXXXX@gmail.com" 
subject="Cache ip4you server full" 
body="Date: $date, Time: $time\n\nResources\n\nuptime: $uptime\nfree 
memory:$freememory\n
cpu load: $cpuload\n
free hdd space: $freehdspace\n
cache: $cache\nmax 
cache: $maxcache\n
Percent used: $percentused %"
:log info "reboot";
/system reboot;
};
Услуги Системного Администратора - Работаю только с Юр. Лицами по договору обслуживания.
Страницы: 1
Ответить
Читают тему (гостей: 1, пользователей: 0, из них скрытых: 0)
Форма ответов
Текст сообщения*
:) ;) :D 8-) :( :| :cry: :evil: :o :oops: :{} :?: :!: :idea:
Защита от автоматических сообщений. Введите символы, изображенные на этой картинке в поле ввода &quote;Код подтверждения&quote;.